17. Türchen: Wenn Standard-Funktionen nicht ausreichen

Excel bietet von Haus aus eine Vielzahl an Funktionen die wir in Formeln verwenden können. Manchmal reicht aber auch diese Vielzahl nicht aus.

Alle Funktionen, die zur Verfügung stehen, sind in dem Dialog Funktion einfügen gelistet und in Themenbereiche aufgeteilt. Am einfachsten wird der Dialog über die fx Schaltfläche geöffnet.

Durch cobby wird diese Liste aktuell um drei nützliche Funktionen erweitert:
- WENNISTLEER
- BILDER.HOLEN
- BILD.HOLEN

Wir möchten hier die erste Funktionen WENNISTLEER vorstellen.

WENNISTLEER(Wert; Wert_falls_leer)
Gibt den festgelegten Wert (Wert_falls_leer) zurück wenn Wert leer ist, andernfalls wird der überprüfte Wert ausgegeben.

Nehmen wir an, wir möchten einen Wert aus Zelle A1 in Zelle A2 anzeigen. Wenn jedoch der Wert in Zelle A1 nicht gesetzt ist, soll die Zelle A2 leer bleiben.

Standardmäßig setzt Excel bei Formeln, die auf eine leere Zelle zeigen, eine 0 an. Das 0-Problem kann mit einer WENN-Formel gelöst werden, bspw. =WENN(ISTLEER(A1); “”; A1), . Dieser Ansatz führt aber dazu, dass zwei Berechnungen stattfinden. Die bessere Lösung ist unsere WENNISTLEER Funktion, die Formel wäre =WENNISTLEER(A1;””) .

Der Vorteil bei dieser Lösung ist, dass die Anzahl der Berechnungen auf das Mindestmaß reduziert wird. Gerade bei großen Datenmengen führt das zu merklich kürzeren Berechnungszeiten.

Anwendungsfall
Der Special-Price von einigen Produkten soll geändert werden, der Preis kommt aus der Spalte Cost.
Wir laden die Daten in cobby und setzen in den Special-Price den Verweis auf die Spalte Cost =[@Cost].

Hierbei fällt auf, dass bei den Produkten ohne hinterlegte Kosten der Special-Price 0 ist. Würden die Produkte so in Magento gespeichert hätten wir Produkte die kostenlos wären.
Um das zu vermeiden kommt nun unsere WENNISTLEER-Funktion zum Einsatz, die Formel =[@Cost] wird durch =WENNISTLEER([@Cost];””) ersetzt.

Nun ist der Special-Price richtig gesetzt und kann über Produkte speichern auch in den Shop übertragen werden.